Topic: Some 2.3RC1 issues

Not sure what other feed back your getting (I don't see these issues when I do a search), but the following happened today:

1) I tried installing 2.3RC1 to use as a test bed. On the first attempt, once the install showed as complete (to this point everything looked OK), I tried running index.php and all I got was a blank screen.

I deleted all files on the server, re-installe 2.3RC1, and this time the only difference was that I did not ask the additional COA's to be included.

It worked the second time.

2) I tried to install Themes (I really like Exclusive theme just released) and got the following message: "the Release file in repository is invalid, or public key is outdated."

I got the same message for installing COA's.

Any thoughts?

Re: Some 2.3RC1 issues

Regarding first point I have no idea. Have you any error messages in error log? You can set $go_debug=1 as usually to see additional error messages.

The problem with theme installing can be related to your php.ini setup. If you have access to server php configuration try setting allow_url_fopen to 1. This issue is fixed in CVS and the patch will be available in next 2.3 release.


Re: Some 2.3RC1 issues

Hmmm... I don't see a php.ini file in any of my Frontaccouting instances, whether it is 2.x or 2.3RC1. I do have php.ini files in some of my other databases I am running, and they all work fine.

As I can't seem to see the php.ini file in the 2.3RC1 download, could you refer me to where I could get one to d/l?

Re: Some 2.3RC1 issues

This is system configuration file, so it is not distributed with FA. I don't know what system are you using - php.ini location depends on it. It is usually placed in /etc/php5/apache2 on Linux using Apache www server.

BTW I have just reported this issue in mantis - you can download fixed files attached to report 248.

5 (edited by avb3 09/23/2010 04:35:42 pm)

Re: Some 2.3RC1 issues


OK... I installed a phpinfo.php file as my php.ini was hidden sad.

I edited it, and now the parameters that report back are as you suggested, in other words, the allow_url_fopen is set to "ON" (actual command line is allow_url_fopen = 1).

This did not help. I logged out, closed browser, cleared my cache and tried again.

I found the new files in Mantis, and was able to find the locations for the and, however, I can not find where the should go... I assume that is a new file.

So two questions, where does the go, and can I change my php.ini back to get rid of the allow_url_fopen, as there has been some suggestion there may be security concerns with it being "on".

Thanks in advance.

Re: Some 2.3RC1 issues

The is new file and should be placed under includes folder in root FA dir.
Yes, you can reverse the changes - the new files should work with any php configuration.

Re: Some 2.3RC1 issues

I start with a new fresh installation an it is sending the same message in the step 3
Release file in repository is invalid, or public key is outdated
FrontAccouting ERP Installation Wizard
Step 3: User Interface Languages Selection

8 (edited by littlez 08/11/2011 03:04:27 am)

Re: Some 2.3RC1 issues

Is there a fix for this problem?
i have the same problem under themes and extension.
When I click add extensions or themes it just says "Release file in repository is invalid, or public key is outdated."
I am using FA 2.3.5
Suse 11.4

Re: Some 2.3RC1 issues

Check Extensions System section in System Diagnostics page under Setup tab.