Topic: Upgrade from 2.3.24 to 2.4.4 on new server

I am trying to move my existing FrontAccounting (v2.3.24) from an old server to a new server (v2.4.4).

My first approach was to build the new server with Ubuntu 18.04, and install FrontAccounting 2.4.4. Then backup the db's on 2.3.24 and restore them onto 2.4.4 on the new server. I soon realised that will not work,. FrontAccounting 2.4.4 refused to upload the backup.

I can't take the current server to 2.4.4 because it runs an old version of Centos and it cannot be upgraded so I cannot make the php requirements.

I then tried installing Ubuntu 16.04 on my server with frontaccounting 2.3.24 but that does not work as I am getting this error when trying to verify the install: Your PHP has to have MySQL extension enabled.

I have been unsuccessful so far in getting past this. Is there a work-around that would allow me to install and FrontAccounting  2.3.24 on Ubunu 16.04 (or even better 18.04)?

Is there another method of transferring the data from one version to another using different servers and OS?

Re: Upgrade from 2.3.24 to 2.4.4 on new server

You have to do it like this.

1. First install a new copy of FA 2.3.26
2. Get backup from 2.3.24
3. Import it to the database to freshly installed FA 2.3.26
4. Now, goto the exports page and export it from FA2.3.26
5. Download a fresh stable FA 2.4.4 and install it without demo data.
6.  Goto backup and restore, and import the file you exported from Fa 2.3.26
7. Now goto upgrade and upgrade it.

It will upgrade your database to newer version. 

This procedure i followed it for FA 2.4.1 upgrade from 2.3.19 So it might work If you have problem with 2.4.4.than go with 2.4.1 and than again one more upgrade to 2.4.4

Hope this helps.

Subscription service based on FA
HRM CRM POS batch Themes

Re: Upgrade from 2.3.24 to 2.4.4 on new server

So I have had some success. I have 2 sets of data to transfer. Both in 2.3.24. I installed 2.4.4 (on Ubuntu 18.04) and uploaded the .sql backup file of a company with the same prefix. The backup did not show up. Then I looked at the folders on the server and the file was there but did not have the correct permissions. I changed it using chown with read everywhere, and then it showed up. This restore worked and the upgrade and as far as I can tell all the data is there.

The second data set actually lives in a different database on the server and it has no prefix. This file doe not upload. It takes a short while and then shows and error triangle  icon at the top of the screen but the actual file is nowhere to be seen. I am going to try a few other things and will report back here.

Re: Upgrade from 2.3.24 to 2.4.4 on new server

This is now completed. I'm not sure why the upload failed but I used Filezilla to transfer the backup to the new server.

For completeness and info to others this is the history of this second dataset. It was originally in seperate MySql db with no prefix. I decided to have a single db on the new server but it is not possible to have non table prefix and table prefix companies in the same db. I loaded the sql file in a text editor and used search replace to create the correct prefixes. This method is not recommended but if you are careful it can be done.