Topic: Tax Inquiry - Does not show output tax info

I am on 2.4.3 and when I run a tax inquiry report, the input tax info does not show anything?  I attach an example below.

Type    Description    Amount    Outputs/Inputs
0%    Charged on sales (Output Tax):    0.00    20.00
0%    Paid on purchases (Input Tax):    0.00    0.00
0%    Net payable or collectible:    0.00   
GST 5%    Charged on sales (Output Tax):    418.97    8,379.38
GST 5%    Paid on purchases (Input Tax):    0.00    0.00
GST 5%    Net payable or collectible:    418.97   
PST 7%    Charged on sales (Output Tax):    58.45    835.00
PST 7%    Paid on purchases (Input Tax):    0.00    0.00
PST 7%    Net payable or collectible:    58.45   
Total payable or refund:    477.42

Re: Tax Inquiry - Does not show output tax info

Anyone can assist?  The Tax Inquiry Report is not working?
The input taxes does not show anything?  Please assist?

Re: Tax Inquiry - Does not show output tax info

Are you using the fixes after the release of FA 2.4.3?

Re: Tax Inquiry - Does not show output tax info

It was after 2.4.3 or after using 2.4.4 that I noticed this problem of output tax showing zeros.   But input taxes shows something.

So right now I rolled back to 2.4.3.  Should I try to go back to 2.4.4?

Re: Tax Inquiry - Does not show output tax info

FA 2.4.4 has not been released as yet. If you are using the post release fixes for FA 2.4.3 then make sure your config.php matches the elements of the config.default.php.

Re: Tax Inquiry - Does not show output tax info

I have also reinstalled 2.4.3 and copied back all the files, and still when I produce a summarized tax report, it shows 0.00 on the inputs and inputs tax.  The output and output taxes does show something however.  Could the database be corrupted?

I have a sample image to show what I meant, but how to display this sample tax report image here?

Re: Tax Inquiry - Does not show output tax info

I see the database version is 2.4.1
I see the log inside this "[05-Nov-2017 03:29:20 UTC] [Notice] Uncompatible extension 'Tax inquiry and detailed report on cash basis' disabled for company 0."
Actually I realized that the extension - Tax inquiry and detailed report on cash basis needs - to be updated. 
But when I went  back to the tax inquiry, it still shows 0"0%    Paid on purchases (Input Tax):    0.00    0.00" and PST 7%    Paid on purchases (Input Tax):    0.00    0.00

Re: Tax Inquiry - Does not show output tax info

It is possible you are using an outdated / incompatible Chart of Accounts. The one in the official repo has it's field order for some tables different from the en_US-new.sql apart from some other changes. What "files" did you copy over?

Make a new install of FA 2.4.3+ by taking the files from the GitMaster that has all the fixes needed as well. Now place the corrected Canadian Chart of Accounts from the FA24extensions repo and place it in your sql folder.

Now make your tax rate entries and fill in some data and check if your problem still remains.

@joe: is this tax scenario prone to such errors?

Re: Tax Inquiry - Does not show output tax info

So I have copied over the new files into the directory and it shows running 2.4.4 and also copied the corrected Canadian Chart of Accounts into the SQL folder, and it still shows 0.00 for all the input tax in the tax summary report.  How do I send you the image snapshot of that blank 0.00 in the summary?

Re: Tax Inquiry - Does not show output tax info

Haven't heard of this before!

Joe

Re: Tax Inquiry - Does not show output tax info

@corporatei: When you upload the latest FA files, it will show v2.4.4 as of now. This does not mean that your chart of Accounts is matched to it. Compare your schema of the database with that of sql/en_US-new.sql and see if there are any table differences or field order and availability differences and synch them to the latter. A blank chart of accounts will necessarily not have any data and hence the tax summary will be 0.

You can install any extension only when logged in as admin in the default company and activate it for any target company from within it. Then, when you are logged in as admin in your target company, you may have to enhance your security role (atleast for the admin user) by enabling the permissions for the new extensions, logout and then login again into the target company.

If you are still in a quandary, PM me access details at a mutually convenient time. I'm possibly half a world away.

Re: Tax Inquiry - Does not show output tax info

@apmuthu I sent you a personal message

Re: Tax Inquiry - Does not show output tax info

I checked the Tax Inquiry report and it does not show the Purchases taxes, only the Sales Invoices taxes.

But in the GL report, I can see  both purchases and sales invoices taxes, when I select the GST Tax account of GL.

Maybe there is a bug in the PHP that does not want to report Purchases Taxes?

In the meantime I had to export as Excel and calculate the purchases taxes manually.

Re: Tax Inquiry - Does not show output tax info

Upload an annotated screenshot somewhere and post the link here.

Also make sure you are using the latest Git Master FA codebase. The changed file list from FA v2.4.3 to v2.4.4 is available in this post (not needed for you now as your are already on FA 2.4.4) and the subsequent changed files are in a succeeding post in the same thread.

Re: Tax Inquiry - Does not show output tax info

corporatei wrote:

I checked the Tax Inquiry report and it does not show the Purchases taxes, only the Sales Invoices taxes.

But in the GL report, I can see  both purchases and sales invoices taxes, when I select the GST Tax account of GL.

Unfortunately I encounter the exact same issue after updating.
I've update last November to 2.4.4 and all seemed working. Continued my accounting up to now and preparing myself for the taxes of the last quarter of 2018. Exactly as above, only Sales taxes are showed and zero Purchases.

Doens't matter which period I select, or even all year. Zero Purchases. Exactly as TS, it does show correctly in GL.

Before posting here, I tried the following;
- Updated from 2.4.4 to 2.4.6
- Clean installation of 2.4.6, importing latest backup (php 5.6)
- Clean installation of 2.4.6, importing latest backup (php 7.3)
- Clean installation of 2.4.6, importing old backup november (php 5.6) - updating DB table set (from v2.3rc to v2.4.1)
- Clean installation of 2.4.6, importing old backup november (php 7.3) - updating DB table set (from v2.3rc to v2.4.1)

All without luck, the Tax Inquiry keeps showing zero's on Purchases.
And yes, if I install a dummy company with 'Standard USA COA + demo data' it works fine. (I use 'Dutch general COA     2.4.1-4')

Not sure if the issue of TS has been resolved via PM. But it would be great if somebody could help wink

Re: Tax Inquiry - Does not show output tax info

Hi,

So if the ''Standard USA COA + demo data' it works fine' so the problem could be with your COA? Check your COA with the std, make sure all accounts are assigned and -> Setup -> System and General GL Setup accounts is matching as per @apmuthu's post 11 above

Re: Tax Inquiry - Does not show output tax info

Hi Poncho1234,

Thank you for your reply. And that makes perfect sense. I had a quick look in the DB with phpMyAdmin, but seems far from easy to compare COA's. Is there an easier way to compare them?

The 'System and General GL Setup' seems alright compared with older versions and compared with USA demo data.

Re: Tax Inquiry - Does not show output tax info

I started rebuilding from my working version back in November (v2.3.25)

Updated to v2.3.26 - fine, no errors
Updated to v2.4.1 - no errors, updated DB, update COA, all fine ----- got the same issue on the Taxes

If I make a fresh install on v2.4.1 with new company and Dutch COA, there is not showing any taxes after some dummy entries.

Other than solving the issue, I'm a bit in doubt .... should I carry on my current version keeping my fingers crossed on a solution. Or should I go back to November with v2.3.5 and redo the last two months......

19 (edited by poncho1234 01/03/2019 05:58:42 pm)

Re: Tax Inquiry - Does not show output tax info

I think i would copy both to a spread sheet and try to align from there.

Another thought, when did you start using the Dutch COA? Might be useful to download the latest Dutch COA and compare that? Seems they were updated approx 9 months ago.

Go back to basics and check everything; i.e. Do you have a GL account assigned to each tax? I s that GL account used elsewhere, etc.

Re: Tax Inquiry - Does not show output tax info

Hi Poncho,

Just completed another test with a clean install of v2.4.6
Default company has an empty (no demo data) USA COA
Added a new company, assigning the Dutch COA

Exported the DB, but have no clue where to look. I was hoping for some community support on this, a FA DB guru who knows in which corner to start looking.

Re: Tax Inquiry - Does not show output tax info

Attached herewith is a make CoA link along with the latest Dutch English CoA for FA 2.4.

Post's attachments

en_NL-CoA_with_Make_Link.zip 26.9 kb, 5 downloads since 2019-01-05 

You don't have the permssions to download the attachments of this post.

Re: Tax Inquiry - Does not show output tax info

Hi Apmuthu, thanks for checking in.
I've downloaded your files, but I'm not sure what I'm supposed to do with it.

Best guess is uploading the SQL to see if it works. If it does (pretty sure it will), how can I apply it on my current 8 years of accounting?

Re: Tax Inquiry - Does not show output tax info

Place the sql file in the sql folder in FA and create a new company using it. Check if all is well first.
Compare the sql dumps of the schema between your existing install and the new sql file and synch them and their data into the new install.

Re: Tax Inquiry - Does not show output tax info

Sorry for my late reply, work picked up.
I'll start digging in to it. I have to travel quite a lot in the upcoming weeks and will do some trial and error on a local LAMPP.

I'll get back to you, but it might take some time. But I do appreciate your help a lot!

Re: Tax Inquiry - Does not show output tax info

Okay, I have definitely reverted to the old version and will stick to that for a while. In between I'm afraid I have to start looking for some other software.

The differences between Apmunthu's dummy NL-COA (I'm still grateful for that, thank you) and the 'official' one from the repository might be severe or not, but way too much for me to handle.. There is too much stuff in there of which I have no clue how it will affect my accounting. Even if I would be able to fix things for now, I would have zero trust that all reports, closure of a book-year etc etc will either be correct or even more screwed by my adjustments.
And if that is not enough, if (big if) I would be able to correct differences between COA's, I'm not sure how to apply these correction on my years of accounting.

I guess this is the end of my 8 years of FA use sad