Topic: WAMP error in second server action

I am able to log into FA and was able to setup a few users. Somewhere along the line it stopped performing actions. It will only perform the 1st action after a page has been loaded. For example, loading Bank and General Ledger -> GL Accounts, then selecting an account will pull the account data. Selecting a second account will not work. This is true on every action throughout FA.

Apache error log:

[Sun Jul 02 17:12:16.427391 2017] [:error] [pid 8420:tid 1168] [client 192.168.56.1:58671] 0:admin:JsHttpRequest.php:388:[before upgrade] Cannot modify header information - headers already sent, referer: http://localhost/frontaccounting/gl/manage/gl_accounts.php?


Error log in frontaccounting/tmp:

[02-Jul-2017 21:12:16 UTC] 0:admin:session.inc:434:[before upgrade] Cannot modify header information - headers already sent


Thanks in advance for any help!

Re: WAMP error in second server action

Are you using FA v2.4.1?
If so, have you incorporated the fixes post release?
What are the versions of PHP/MySQL in use?
If on Linux (version and type in use?), make sure the permissions of the (upgraded) files match the installation platform.
What is the browser and version you are using?

Re: WAMP error in second server action

Hi,
I did implement the fixes posted.

Yes, tried it on FA v2.3 and v2.4.1.
WAMP v3.0.9
MySQL v5.7.14
PHP v5.6.25

Using Chrome 59.0.3071.115

I know it's the WAMP server installation because I setup a Raspberry Pi server and FA is running just fine on it. I will probably run it on the Raspberry PI, runs faster anyway.

Last edited by markr (07/03/2017 01:16:34 pm)

Re: WAMP error in second server action

MySQL 5.7 may be the issue. By default the strict mode is on in MySQL v5.7 onwards. Hence all dates and timestamp fields no longer respect the 0000-00-00 00:00:00 values. Details are in this post.

PHP 5.6 too may have issues with array declaration syntax.