Topic: Loading Error

I had install FA the local environment.
Every time when I tried to add records, no matter is need new invoice, new items or see exchange rates, after I check add/search it will load a while and then show the warning sign above.
Do I not install properly? or have I miss out something?
I had tried to reinstall once but the result is the same. Please help me.

Anyway my PHP version: 5.6.25

Last edited by Yan Shuang (01/09/2017 08:56:43 am)

Re: Loading Error

what warning sign?

Re: Loading Error

A yellow triangle with an exclamation mark in the centre.

Re: Loading Error

that is not helpful enough for me to know what you are talking about....

Re: Loading Error

Eg. I tried to get currency exchange rate. When I click on "Get" , the warning sign above is shown and value is not shown.

/!\  PS. I cant attached the image here to descide my situation.
---

Re: Loading Error

I would start by checking your web server logs, I don't recognize your symptoms, but it sounds like something should show up in there...

Re: Loading Error

May I know how do I check the web server logs? please provide details if possible

Re: Loading Error

Windows or Linux Server?
PHP/MySQL versions?

Re: Loading Error

Windows
PHP version: 5.6.25
SQL version: 5.7.14

Re: Loading Error

Disable the MySQL strict setting and restart MySQL. Later versions of MySQL do not like zero dates: 0000-00-00 and 0000-00-00 00:00:00.

Search your web server folder for error log files. In Windows XAMPP 1.7.3 / Apache it will generally be in WEBSERVER_FOLDER\apache\logs\error.log

Re: Loading Error

I had disable the SQL strict setting via SET sql_mode = '' for the database I had created for this. And my error log has nothing,

Re: Loading Error

MySQL I expect has been restarted.
Which version of FA are you using?
Where did you take it from?

The latest versions are at:
FA 2.3.25+
FA 2.4RC1+

Re: Loading Error

FA 2.3.25

I downloaded from the link from https://sourceforge.net/projects/frontaccounting/

Re: Loading Error

Use the links from my earlier post. The official SF link / release download has some bugs fixed later in the repos.

Re: Loading Error

Thank you for your reply. I will download it and try again

Re: Loading Error

I had installation successfully. I had test out some of the functions and it look quite okay for now. I will do more testing to confirm that it is working as per normal.
Once again thank you for all your help.